Составьте программу вычисления в массиве B(N) минимального среди положительных элементов и его номера

Составьте программу вычисления в массиве B(N) минимального среди положительных элементов и его номера
Гость
Ответ(ы) на вопрос:
Гость
const N=10; var a: array [0..N] of integer;     i, m: integer; begin      for i := 0 to N do          a[i] := random(1000) - 500; { Надо же что-то в массив закинуть =) }      for i := 0 to N do          if ((a[i] > 0) and (a[i] > a[m])) then             m := i;      writeln('[', m, '] => ', a[m]); end.
Гость
min:=b[1]; max:=b[1]; for i:=1 to n do begin if minb[i] then max:=b[i]; max:=b[i]; end;
Не нашли ответ?
Ответить на вопрос
Похожие вопросы