Составьте программу, заменяющую меньшее из двух данных чисел суммой, а большее – произведением этих чисел. С помощью оператора выбора- case
Составьте программу, заменяющую меньшее из двух данных чисел суммой, а большее – произведением этих чисел. С помощью оператора выбора- case
Ответ(ы) на вопрос:
var a,b,min,max,f:integer;
begin
readln(a,b);
min:=a+b;
max:=a*b;
if a>b then f:=1 else f:=2;
case f of
1: begin a:=max; b:=min end;
2: begin a:=min; b:=max end;
end;
writeln(a,b);
end.
Не нашли ответ?
Похожие вопросы