СРОЧНО!!! Составить программу на языке Паскаль. Найдите среднее ариыметическое натуральных чисел от 1 до n кратных 5.
СРОЧНО!!! Составить программу на языке Паскаль.
Найдите среднее ариыметическое натуральных чисел от 1 до n кратных 5.
Ответ(ы) на вопрос:
program z1;
var a:array[1..10000] of longint;
k,i,s,r:longint;
v:real;
begin
read(k);
for i:=1 to k do
read(a[i]);
s:=1;
r:=0;
v:=0;
for i:=1 to k do
if (a[i] mod 5)=0 then begin
s:=s*a[i];
r:=r+1;
end;
v:=s/r;
write(v);
end.
{на основе формулы арифметической прогессии}
var
n: integer;
begin
readln(n);
writeln((5+5+5*(n div 5 -1))/2) ;{((a1+a1+d*(n-1))/2)}
end.
{или перебором без математики}
var
i,n,k: integer;
s:real;
begin
k:=0;
readln(n);
for i:=1 to n do
if i mod 5=0 then begin s:=s+i; k:=k+1; end;
writeln(s/k) ;
end.
Пример
n=100
summa=52.5
Не нашли ответ?
Похожие вопросы