СРОЧНО!Составить программу(10класс): дано предложение,заменить в нем все запятые на точки и удалить из предложения подстрочку по запросу пользователя.

СРОЧНО!Составить программу(10класс): дано предложение,заменить в нем все запятые на точки и удалить из предложения подстрочку по запросу пользователя.
Гость
Ответ(ы) на вопрос:
Гость
uses Crt;  var  Stroka, PodStroka: string;      poz, i: integer; begin  ClrScr;  Write(' Stroka :   '); ReadLn (Stroka);  for i:= 1 to length (Stroka) do      if Stroka[i]=',' then Stroka[i]:='.';  WriteLn(' Zamena :   ', Stroka);  WriteLn;  Write(' PosStroka :   '); ReadLn (PodStroka);  poz:=Pos(PodStroka, Stroka);  Delete (Stroka,poz,length(PodStroka));  WriteLn(' Udalili :   ', Stroka);  ReadLn; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы