!!!!!!!ТОЛЬКО ДЛЯ ЗНАЮЩИХ!!!!!!!!! Составить программу, которая позволяет ввести два числа в первой строке, и один из знаков (+, -, *, /) во второй строке. На экран должен быть выведен результат выполнения соответствующего ариф...
!!!!!!!ТОЛЬКО ДЛЯ ЗНАЮЩИХ!!!!!!!!!
Составить программу, которая позволяет ввести два числа в первой строке, и один из знаков (+, -, *, /) во второй строке. На экран должен быть выведен результат выполнения соответствующего арифметического действия. Для ввода знака использовать вспомогательную переменную типа char.
Ответ(ы) на вопрос:
var
s: char;
a, b: real;
begin
Write('Введите два числа ');
Readln(a, b);
Write('Введите действие (+, -, *, /) - ');
Readln(s);
case s of
'+': writeln(a, ' + ', b, ' = ', a + b);
'-': writeln(a, ' - ', b, ' = ', a - b);
'*': writeln(a, ' * ', b, ' = ', a * b);
'/': if (b=0) then writeln('На ноль делить нехорошо - бесконечность получится') else writeln(a, ' / ', b, ' = ', a / b);
End;
end.
Var Ch : Char;
a,b : Integer;
Begin
Readln(a,b);
Readln(Ch);
Case Ch of
'+' : Writeln(a+b);
'-' : Writeln(a-b);
'*' : Writeln(a*b);
'/' : Writeln(a/b);
end;
end.
Не нашли ответ?
Похожие вопросы