Требуется написать программу которая по числу n(1 меньше n меньше 10000000000) найдет максимальное число k такре что nделится на k квадрат
Требуется написать программу которая по числу n(1
Ответ(ы) на вопрос:
unsigned long k = 10000000000;
for(k = 10000000000; k > 2; k--) if(n % (k*k) == 0) break;
printf(k);
Не нашли ответ?
Похожие вопросы