УМОЛЯЮ, ПОМОГИТЕ!!! Напишите программу, которая в последовательности натуральных чисел определяет среднее арифметическое всех чисел, кратных 2 и оканчивающихся на 8. Программа получает на вход натуральные числа, количество введ...
УМОЛЯЮ, ПОМОГИТЕ!!! Напишите программу, которая в последовательности натуральных чисел определяет среднее арифметическое всех чисел, кратных 2 и оканчивающихся на 8. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число: среднее арифметическое всех чисел, кратных 2 и оканчивающихся на 8.
Ответ(ы) на вопрос:
Гость
var
s,n,k:integer;
begin
Writeln('введите натуральные числа, 0 - окончание ввода');
k:=0; s:=0;
repeat
Read(n);
if n<>0 then
if n mod 10 = 8 then begin k:=k+1; s:=s+n end
until n=0;
if k>0 then Writeln(s/k:0:4)
else Writeln(0)
end.
Пример
введите натуральные числа, 0 - окончание ввода
34 17 8 32 1424 28 7 0
18.0000
Не нашли ответ?
Похожие вопросы