Я написала программу, но там где то ошибка, решение не верное выходит, помогите найти ошибку. Вот задание: Написать программу, подсчитывающую среднее арифметическое всех элементов массива. var i,n:integer; g: real; a:array[1..1...
Я написала программу, но там где то ошибка, решение не верное выходит, помогите найти ошибку. Вот задание: Написать программу, подсчитывающую среднее арифметическое всех элементов массива.
var i,n:integer;
g: real;
a:array[1..10] of integer;
begin
for i:=1 to 10 do
begin
write ('введите ',i,'элемент');
read(a[i]);
end;
n:=0;
for i:=1 to 10 do
n:=n+a[i];
write (n);
g:=n/10;
write (g);
end.
Ответ(ы) на вопрос:
Гость
У Вас всё считает правильно, но рекомендую Вам изучить вопрос: "В чем отличие между Write и Writeln?"
При выводе добавьте "ln"
Не нашли ответ?
Похожие вопросы