Задача 1 Cоставить программу,которая позволяет ввести строку s,затем после каждой буквы "а" вставить пробел. задача 2 Составить программу,которая удаляет в строке S все буквы "о"
Задача 1 Cоставить программу,которая позволяет ввести строку s,затем после каждой буквы "а" вставить пробел. задача 2 Составить программу,которая удаляет в строке S все буквы "о"
Ответ(ы) на вопрос:
На всякий случай сделал проверку и на русские, и на английские.
задача 1.
uses crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
repeat
if (s[i]='a') or (s[i]='а') then
s:=copy(s,1,i)+' '+copy(s,i+1,length(s));
i:=i+1;
until i=length(s)+1;
writeln(s);
end.
задача 2.
uses crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
repeat
if (s[i]='о') or (s[i]='o') then
s:=copy(s,1,i-1)+' '+copy(s,i+1,length(s));
i:=i+1;
until i=length(s)+1;
writeln(s);
end.
Не нашли ответ?
Похожие вопросы