Задача 3. Написать программу, определяющую, лежит ли точка с указанными координатами А (x, y) на окружности радиуса R с центром в начале координат (может лежать на окружности, внутри окружности, вне окружности)PS: Pascal(не тур...
Задача 3. Написать программу, определяющую, лежит ли точка с
указанными координатами А (x, y) на окружности радиуса R с центром в начале
координат (может лежать на окружности, внутри окружности, вне окружности)
PS: Pascal(не турбо)
Всем буду благодарен!
Ответ(ы) на вопрос:
Var
x,y, r: Iinteger;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln®;
If (sqr(x)+sqr(y))=r then writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.
Не нашли ответ?
Похожие вопросы