Задача 4.Напишите программу ,которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел,не превосходящих 256.Программа получает на выход целые числа ,количество введенных ч...
Задача 4.Напишите программу ,которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел,не превосходящих 256.Программа получает на выход целые числа ,количество введенных чисел неизвестно,последовательность чисел заканчивается числом 0 (0-признак окончания ввода,не входит в последовательность.)Количество чисел не превышает 1000.Введенные числа по модулю не превышают 30 000.Программа должна вывести два числа:длину последовательности и сумму положительных чётных чисел,не превосходящих 256.
Ответ(ы) на вопрос:
Гость
var x,k:integer;
begin
k:=0;
repeat
writeln('Введите число');
read(x);
if (x>0) and (x<=256) then k:=k+1;
until x=0;
writeln('Количество положительных чисел <=256 = ',k);
end.
Не нашли ответ?
Похожие вопросы