Задача в delphi. Составить программу для нахождения суммы: 2!+3!+4!+...+N!

Задача в delphi. Составить программу для нахождения суммы: 2!+3!+4!+...+N!
Гость
Ответ(ы) на вопрос:
Гость
//Создать консольное приложение program ConsoleProgram;  {$APPTYPE CONSOLE} var valueN,sum,i,i2,tmp:longint; begin sum:=0; readln(valueN); for i:=1 to valueN do begin tmp:=1; for i2:=1 to i do tmp:=tmp*i2; sum:=sum+tmp; end; writeln(sum); readln; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы