Задан двумерный массив A из 5-ти строк и 2-х столбцов.Составить программу,которая формирует одномерный массив В,каждый элемент которого есть произведение элементов массива A в строке.
Задан двумерный массив A из 5-ти строк и 2-х столбцов.Составить программу,которая формирует одномерный массив В,каждый элемент которого есть произведение элементов массива A в строке.
Ответ(ы) на вопрос:
program gt;
var a:array[1..5,1..5]of integer;
b:array[1..5]of integer;
s,i,j:integer;
begin
for i:=1 to 2 do
begin
s:=1;
for j:=1 to 5 do
begin
read(a[i,j]);
s:=s*a[i,j];
end;
b[i]:=s;
end;
for i:=1 to 5 do
write(b[i],' ');
end.
Не нашли ответ?
Похожие вопросы