Задание 4 Написать программу, создающую одномерный массив из 15 элементов. Значения членов массива вводятся при выполнении программы. Программа должна находить минимальный и максимальный члены массива и их номера.

Задание 4 Написать программу, создающую одномерный массив из 15 элементов. Значения членов массива вводятся при выполнении программы. Программа должна находить минимальный и максимальный члены массива и их номера.
Гость
Ответ(ы) на вопрос:
Гость
var  a: array[1..15] of integer;   i, imin, imax: integer; begin   imax:=1;   imin:=1;   for i:=1 to 15 do     begin       readln(a[i]);       if a[i]a[imax] then imax:=i;     end;   writeln('Минимальный член массива ', a[imin], ', его номер ', imin);   writeln('Максимальный член массива ', a[imax], ', его номер ', imax); end.
Гость
Программа на Паскаль. Program Dik; Var i, min, max, minnum, maxnum: integer; a: array[1..15] of integer; Begin for i:= 1 to 15 do    readln(a[i]); max:=a[1]; min:=a[1]; for i:= 1 to 15 do begin    if a[i]max then begin       max:=a[i]; maxnum:=i;    end; end; writeln('max=', max); writeln('min=', min); writeln('maxnum=', maxnum); writeln('minnum=', minnum); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы