Здравствуйте. Нужна ваша помощь. Нужно составить программу для языка c++, выполняющую данную задачу:
Здравствуйте. Нужна ваша помощь.
Нужно составить программу для языка c++, выполняющую данную задачу:
Ответ(ы) на вопрос:
#include
//входные данные#define n 4#define m 3
int main(){ //Входные данныеfloat a[n] = { 2.1, 3.2, 4.8, 5.7 };
float b = 18; float sqrt_b = sqrt(b); float c[m] = { 15, 25, 25 };
//результат float y = 0; //временная переменная float tmp; printf("\n y = sum(1;%d){a[i] + sqrt(b)} + mng(1;%d){sin(c)}", n, m);
//Подсчет суммы tmp = 0; int i = -1; while (++i < n) tmp += (a[i] + sqrt_b); //Запись в результат y += tmp;
//Подсчет произведения tmp = 1; i = -1; while (++i < m) tmp *= (sin(c[i])); //Запись в результат y += tmp;
//Вывод printf(" \n >> y = %g\n",y);
system("pause>>void"); return 0;}
Не нашли ответ?
Похожие вопросы