1. дано слово. удвоить в нем все буквы, стоящие на четных местах 2. составьте программу, определяющую, на какую букву заканчивается второе слово в предложении

1. дано слово. удвоить в нем все буквы, стоящие на четных местах 2. составьте программу, определяющую, на какую букву заканчивается второе слово в предложении
Гость
Ответ(ы) на вопрос:
Гость
for i := 1 to length(s) do begin     res := res + s[i];     if i mod 2 = 0 then        res := res + s[i]; end; writeln(res);     i := Pos(" ",s);{ищем первый пробел} Delete(s;i;1);{удаляем первый пробел} i := Pos(" ",s);{ищем второй пробел, котрый теперь первый} writeln(s[i-1]);{выдаем знак который находится перед пробелом}      
Не нашли ответ?
Ответить на вопрос
Похожие вопросы