1) Составьте программу, меняющую в слове X букву "о" на букву "и", если "о" стоит на четном месте. 2)Составьте программу, меняющую в слове Х все сочетания "ва" на "к". ЗАРАНЕЕ СПАСИБО)
1) Составьте программу, меняющую в слове X букву "о" на букву "и", если "о" стоит на четном месте.
2)Составьте программу, меняющую в слове Х все
сочетания "ва" на "к".
ЗАРАНЕЕ СПАСИБО)
Ответ(ы) на вопрос:
1.
Var
s:string;
i:integer;
Begin
Write('Введите строку ');
Readln(s);
for i:= 1 to length(s) do
if ((s[i]='о')or(s[i]='o'))and((i mod 2) = 0) then s[i]:='и';
Writeln(s);
End.
2.
Var
s:string;
i,j:integer;
Begin
Write('Введите строку ');
Readln(s);
s:=s+' ';
for i:= 1 to length(s) do
if (s[i]='в')and(s[i+1] = 'а') then Begin s[i]:='к'; for j:=(i+1) to (length(s)-1) do s[j]:=s[j+1]; end;
Writeln(s);
End.
Не нашли ответ?
Похожие вопросы