1)      Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна выводить соответствующее текстовое сообщение. Программист сделал в программе ошибки. va...

1)      Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у, z. Программа должна выводить соответствующее текстовое сообщение. Программист сделал в программе ошибки. var х, у, z: real;   begin  readln (x, у, z);    if (x + y > z) then   begin  if (x + z > y) then i f (y + z > x) then writeln('треугольник построить можно'); end else writeln('треугольник построить нельзя'); end  Последовательно выполните задания: 1.  Приведите пример таких чисел х, у, z, при которых программа неверно решает поставленную задачу. 2.  Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы (можно указать один из способов доработки исходной программы). 3.  Укажите, как можно доработать программу, чтобы она вместо вложенных операторов IF содержала логическую операцию AND.  
Гость
Ответ(ы) на вопрос:
Гость
1)Программист не сделал ошибки 2)программа и так правильно работает 3) program chik; var х,у,z:real;    begin   readln (x, у, z);    if (x+y>z)and(x+z>y)and(y+z>x) then writeln('треугольник построить можно') else writeln('треугольник построить нельзя'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы