1.Дано целое число. Составить программу, определяющую, какое число было введено: положительное, отрицательное или ноль 2. Вводятся два числа. Сравнить эти числа.
1.Дано целое число. Составить программу, определяющую, какое число было введено: положительное, отрицательное или ноль
2. Вводятся два числа. Сравнить эти числа.
Ответ(ы) на вопрос:
#include
#include
void main() {
int digit;
std::cin >> digit;
if(digit>0) {
std::cout << "+" << std::endl;
} else if (digit<0) {
std::cout << "-" << std::endl;
} else {
std::cout << "0" << std::endl;
}
int digit1, digit2;
std::cin >> digit1;
std::cin >> digit2;
if(digit1>digit2 && digit1 !=0 && digit2 !=0) {
std::cout << digit1 << " > " digit2 << std::cout;
} else {
std::cout << digit1 << " < " digit2 << std::cout;
}
_getch();
return 0;
}
Не нашли ответ?
Похожие вопросы