1)используя справочник записать значение процедур delete и insert . 2)написать программу позволяющею разделить на отдельные цифры число любой длины

1)используя справочник записать значение процедур delete и insert . 2)написать программу позволяющею разделить на отдельные цифры число любой длины
Гость
Ответ(ы) на вопрос:
Гость
1) procedure Insert(source: string; var s: string; index: integer);          Вставляет подстроку source в строку s с позиции indexprocedure Delete(var s: string; index, count: integer);          Удаляет из строки s count символов с позиции index 2) var s:string; i,n,code:integer; begin write('Введите длинное число:'); readln(s); for i:=1 to length(s) do  begin  val(s[i],n,code);  if code=0 then writeln(n);  end; end. Пример: Введите длинное число:3456810285 3 4 5 6 8 1 0 2 8 5 Если не требуется выполнять арифметических действий с цифрами, то можно так: var s:string; i:integer; begin write('Введите длинное число:'); readln(s); for i:=1 to length(s) do writeln(s[i]); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы