1.Найти двухзначные числа, которые делятся на сумму своих цифр 2.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.

1.Найти двухзначные числа, которые делятся на сумму своих цифр 2.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
Гость
Ответ(ы) на вопрос:
Гость
var i,m,sum:Integer; Begin  for i:=10 to 99 do   begin    m:=i mod 10;    n:=i div 10;    sum:=m+n;    if (i mod sum = 0) then Writeln(i);   end;  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы