1. Описать массив, подходящий для представления роста (в см) призывников в РА из 115 группы. 2. Написать программу, заполняющую массив данными (не упорядоченными) с клавиатуры и печатающую средний рост призывников. 3. Включить ...

1. Описать массив, подходящий для представления роста (в см) призывников в РА из 115 группы. 2. Написать программу, заполняющую массив данными (не упорядоченными) с клавиатуры и печатающую средний рост призывников. 3. Включить в программу функцию, определяющую порядковый номер самого высокого призывника. 4. Включить в программу функцию, определяющую количество призывников, имеющих рост не более чем на 10% отличающийся от роста самого высокого призывника (включая его) Массивы одномерные Рост примерный Паскаль АВС
Гость
Ответ(ы) на вопрос:
Гость
const  n=5; type  MyArr=array[1..n] of integer; var ar:MyArr; i,maxi,val:integer; k:real; function Maxii(ar:MyArr): integer; var i,max:integer; begin; Max:=-2147483648; for i:=1 to n do if ar[i]>max then begin;  max:=ar[i];  maxii:=i; end; end; function Amp(ar:MyArr):integer; var i,max,s:integer; p:real; begin; Max:=-2147483648; for i:=1 to n do if ar[i]>max then max:=ar[i]; p:=max/100*10; for i:=1 to n do if ar[i]>=max-p then inc(s); Amp:=s; end; begin; for i:=1 to n do begin; readln(ar[i]); k:=k+ar[i]; end; k:=k/n; writeln('Средний рост:',k); maxi:=maxii(ar); writeln('Самый высокий призывник:',maxi); val:=Amp(ar); writeln('4:',val); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы