1.С клавиатуры вводят слово и символ.Составьте программу ,которая определяет позицию данного символа.

1.С клавиатуры вводят слово и символ.Составьте программу ,которая определяет позицию данного символа.
Гость
Ответ(ы) на вопрос:
Гость
Var c: Char; s: String; i,k,p: Integer; Begin ReadLn(c); {Чтение заданного символа} ReadLn(s); {Чтение заданного слова} p:= Pos(c,s); {Определяем позицию символа} If (p=0) Then {Функция вернёт 0, если символ не будет найден} WriteLn('Такого символа в слове нет.') Else {Если символ есть, то ...} Begin WriteLn('Указанный символ расположен на позиции: ',p); k:= 0; {k хранит количество вхождений} p:= Length(s); {p хранит длину строки(слова)} For i:=1 To p Do {Пробегаем по всем символам слова} If (s[i]=c) Then inc(k); {Если символ совпадает, увеличиваем на 1 переменную k} WriteLn('Количество вхождений данного символа: ',k); End; End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы