1)Составить программу для поиска наибольшего из 4 чисел. 2) Cоставить программу поиска наибольшего из трех чисел с учетом того, что числа могут быть равны.Только плз чтобы там было типо такого : Var a,b,c,d max:integer
1)Составить программу для поиска наибольшего из 4 чисел.
2) Cоставить программу поиска наибольшего из трех чисел с учетом того, что числа могут быть равны.
Только плз чтобы там было типо такого : Var a,b,c,d max:integer
Ответ(ы) на вопрос:
Гость
1)
var
a, b, c, d, max: integer;
begin
readln(a, b, c, d);
if(a > b) and (a > c) and (a > d) then max := a
else if(b > a) and (b > c) and (b > d) then max := b
else if(c > a) and (c > b) and (c > d) then max := c
else max := d;
write(max);
end.
2)
var
a, b, c, max:
integer;
begin
readln(a, b, c);
if(a > b) and (a > c) then max := a
else if(b > a) and (b > c) then max := b
else max := c;
write(max);
end.
Не нашли ответ?
Похожие вопросы