2. Написать программу, которая вводит массив из N целых чисел и выводит на экранномера отрицательных элементов и сами эти элементы. Протестировать программу для следующих массивов: а) 3,5,-2,0,-6,-8,1б) -1,-2,-3,-4,0,-1,2,3. По...

2. Написать программу, которая вводит массив из N целых чисел и выводит на экранномера отрицательных элементов и сами эти элементы. Протестировать программу для следующих массивов: а) 3,5,-2,0,-6,-8,1б) -1,-2,-3,-4,0,-1,2,3. Пожалуйста)))
Гость
Ответ(ы) на вопрос:
Гость
Var mas:array[1..100] of real; i:integer; y:string; Begin  write('Вводите элементы массива, когда закончите введите Y: ');readln(y);  for i:=1 to 100 do begin if (y='Y') then i:=101 else         begin mas[i]:=strTofloat(y); readln(y); end;End; for i:=1 to 100 do begin if (mas[i]<0) then writeln('Номер элемента:',i,' Элемент:',mas[i]);end; End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы