20 Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число S. Укажите такое наименьшее число x, при вводе которого алгоритм печатает пятизначное число Паскаль var...

20 Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число S. Укажите такое наименьшее число x, при вводе которого алгоритм печатает пятизначное число Паскаль var x,d,R,S: longint; begin readln(x); S := x; R := 0; while x>0 do begin d := x mod 2; R := 10*R + d; x := x div 2 end; S := R + S; writeln(S) end.
Гость
Ответ(ы) на вопрос:
Гость
X = 49. Программа обработает его и выдаст "94". Сумма цифр 4 + 9 = 9 + 4 = 13.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы