4 «Условный оператор» Написать программу: Дано четырехзначное число. Определить, входит ли в него цифра 6.

4 «Условный оператор» Написать программу: Дано четырехзначное число. Определить, входит ли в него цифра 6.
Гость
Ответ(ы) на вопрос:
Гость
uses crt; var a,b,c,d,ch:integer; begin a:=0; b:=0; c:=0; d:=0; readln(ch); a:=ch div 1000; b:= (ch div 100) mod 10; c:=(ch div 10)mod 10; d:=ch mod 10; if ((a =6) or ( b = 6) or (c = 6 ) or ( d = 6)) then writeln('YES') else writeln('NO'); readln; end.
Гость
Program spinogryz21; var   x, i: integer;   yes: boolean; begin   yes := FALSE;   write('Введите число Х ');   readln(x);   for i := 1 to 4 do   begin     if (x mod 10) = 6 then yes := TRUE;     x:=x div 10;   end;   if yes then writeln('6 входит в число Х')   else writeln('6 не входит в число Х'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы