80 БАЛЛОВ!!!Помогите Паскаль!!!Нужно составить программу которая проверяла является ли простым числом,введенное с клавиатуры числом
80 БАЛЛОВ!!!Помогите Паскаль!!!Нужно составить программу которая проверяла является ли простым числом,введенное с клавиатуры числом
Ответ(ы) на вопрос:
program zhn;
var
n,i,sum:integer;
begin
write('Введите значение: ');
readln(n);
for i:=1 to n do begin
if n mod i = 0 then sum:=sum+1;
end;
if sum = 2 then writeln('Число ',n,' является простым.')
else writeln('Число ',n,' НЕ является простым.');
end.
Не нашли ответ?
Похожие вопросы