«Бегущая строка». Составить программу в паскале. которая изобразит в нижней части экрана строку, «бегущую» справа налево. Строка должна менять свой цвет.

«Бегущая строка». Составить программу в паскале. которая изобразит в нижней части экрана строку, «бегущую» справа налево. Строка должна менять свой цвет.
Гость
Ответ(ы) на вопрос:
Гость
Uses CRT; Const Delay = 200; //Задержка в миллисекундах Line = 22; //Номер строки, на которой будет текст Text = 'Бегущая строка'; //Текст бегущей строки Var  i: Integer; s: String; Begin   s := Text;   For i := 1 To 80 Do   Begin     GotoXY(1, Line);     TextColor(Random(14) + 1);      WriteLn(s);     s := ' ' + s;     Sleep(Delay);   End; End.
Гость
//Pascal ABC.NET 3.1 сборка 1256 uses   GraphABC;  Const  s='Sample text';//текст  d=10;//задержка  Var  x:integer; begin randomize; x:=windowwidth; while x>=0 do  begin   textout(x,windowheight-20,s);   setfontcolor(rgb(random(255),random(255),random(255)));   sleep(d);   dec(x);   clearwindow;  end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы