Числа Фибоначчи определяются следующими формулами: f0=f1=1; fn=fn-1+fn-2, при n больше =2 на вход программе подается целое неотрицательное n= меньше 40 выведите n-е число Фибоначчи. Массив в программе не использовать
Числа Фибоначчи определяются следующими формулами: f0=f1=1;
fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n=<40 выведите n-е число Фибоначчи. Массив в программе не использовать
Ответ(ы) на вопрос:
program gt;
var n,f1,f2,i,f:integer;
begin
readln(n);
f1:=1;f2:=1;
for i:=2 to n do
begin
f:=f1+f2;
f1:=f2;
f2:=f;
end;
writeln(f2);
end.
Не нашли ответ?
Похожие вопросы