Дан массив a состоящий из 30 целых чисел — рост 30 учеников школы. Сколько из них имеет рост больше 170 см? Можно ли сформировать баскетбольную команду (в команде должно быть не менее пяти человек ростом больше 170 см)? Формат ...

Дан массив a состоящий из 30 целых чисел — рост 30 учеников школы. Сколько из них имеет рост больше 170 см? Можно ли сформировать баскетбольную команду (в команде должно быть не менее пяти человек ростом больше 170 см)? Формат входных данных На единственной строке через пробел записаны 30 целых чисел (100≤ai≤220) — росты учеников. Формат выходных данных Требуется в первой строке вывести единственное число — количество учеников, рост которых не меньше 170. На следующей строке вывести «YES», если баскетбольную команду набрать можно, иначе вывести «NO».
Гость
Ответ(ы) на вопрос:
Гость
//Так рост больше или не меньше 170? В данном решении рассматривается вариант с больше //Dev-C++ 5.11 (C) #include int main(void)  {const int n=30;  int arr[n],k;  k=0;  for(int i=0;i170)    k++;}  printf("%d \n",k);  if(k>=5)   printf("YES");  else   printf("NO");  return 0;}
Не нашли ответ?
Ответить на вопрос
Похожие вопросы