Дан массив из n элементов. Необходимо вывести количество элементов, которые больше своих «соседей» (следующего и предыдущего элементов). Формат входных данных С клавиатуры вводится натуральное число n (n≤100). На следующей стро...
Дан массив из n
элементов. Необходимо вывести количество элементов, которые больше своих «соседей» (следующего и предыдущего элементов).
Формат входных данных
С клавиатуры вводится натуральное число n (n≤100). На следующей строке через пробел вводятся n элементов массива. Все числа целые и по модулю не превосходят 100.
Формат выходных данных
В качестве ответа выведите единственное число — количество искомых элементов.
Ответ(ы) на вопрос:
//Dev-C++ 5.11 (C)
#include
int main(void)
{int arr[100],n,k;
scanf("%d",&n);
k=0;
for(int i=0;iarr[i+1])k++;
else
if(i==n-1 && arr[i]>arr[i-1])k++;
else
if(arr[i]>arr[i-1] && arr[i]>arr[i+1])k++;
printf("%d",k);
return 0;}
Не нашли ответ?
Похожие вопросы