Дан массив А, состоящий из 6 элементов. Вывести элементы массива. Изменить порядок следования элементов массива на обратный, вывести инвертированный массив.   Помогите, пожалуйста, составить программу в паскале!!!   Вот, наприм...

Дан массив А, состоящий из 6 элементов. Вывести элементы массива. Изменить порядок следования элементов массива на обратный, вывести инвертированный массив.   Помогите, пожалуйста, составить программу в паскале!!!   Вот, например, я начала.   Program z10; VAR p, i: Integer; x: Array [1..6] of integer; Begin For i:=1 to 6 Do begin p:=a[i]; А как дальше поменять местами остальные элементы??
Гость
Ответ(ы) на вопрос:
Гость
1) просто выводим элементы наооборот program gt; var a:array[1..6]of longint; n,i:integer; begin read(n); for i:=1 to n do begin read(a[i]); end; for i:=6 downto 1 do begin write(a[i],' '); end; end. 2) добавляем дополнительный массив b program gt; var a,b:array[1..6]of longint; n,k,i:integer; begin read(n); k:=7; for i:=1 to n do begin read(a[i]); k:=k-1; b[k]:=a[i]; end; for i:=1 to 6 do begin write(b[i],' '); end; end. 3) Изменяем элементы массива без дополнительных элементов Program z10; VAR  p, i: Integer;  x: Array [1..6] of integer; Begin For i:=1 to 3 Do  begin p:=a[i]; a[i]:=a[6-i+1]; a[6-i+1]:=p; end; for i:=1 to 6 do begin write(a[i],' '); end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы