Дан массив a состоящий из n целых чисел. Требуется найти количество пар соседних элементов массива, являющихся четными числами. Формат входных данных На первой строке записано целое число n (0 На второй строке через пробел запи...

Дан массив a состоящий из n целых чисел. Требуется найти количество пар соседних элементов массива, являющихся четными числами. Формат входных данных На первой строке записано целое число n (0 На второй строке через пробел записаны n чисел (−1000≤ai≤1000) — элементы массива. Формат выходных данных Требуется вывести единственное число — количество пар четных чисел.
Гость
Ответ(ы) на вопрос:
Гость
var   i, k, n: integer;    a: array[1..10000]of integer;  begin   k := 0;   readln(n);    for i := 1 to n do read(a[i]);    for i := 2 to n do if (a[i - 1] mod 2 = 0) and (a[i] mod 2 = 0) then k := k + 1; write(k); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы