Дан массив из 12 элементов, в котором есть положительные и отрицательные числа (нол

Дан массив из 12 элементов, в котором есть положительные и отрицательные числа (ноль тоже есть): а1=5, а2=4, а3=-3, а4=1, а5=0, а6=-4, а7=, а8=25, а9=-8, а10=-5, а11=-17, а12=-1. Составьте программу, в которой 1 вариант: Все отрицательные числа меняются на «1», все положительные на «-5», нулевые не трогаются. Вывести на экран исходный и полученный массив.
Гость
Ответ(ы) на вопрос:
Гость
Const n=12; a:array[1..n] of integer=(5,4,-3,1,0,-4,7,25,-8,-5,-17,-1); var i:integer; begin for i:=1 to n do write(a[i]:4); writeln; for i:=1 to n do  if a[i]<0 then a[i]:=1            else if a[i]>0 then a[i]:=-5; for i:=1 to n do write(a[i]:4); end. Результат: 5 4 -3 1 0 -4 7 25 -8 -5 -17 -1 -5 -5 1 -5 0 1 -5 -5 1 1 1 1
Не нашли ответ?
Ответить на вопрос
Похожие вопросы