Дан массив из n чисел. Найти номер первого чётного элемента массива; если чётных элементов нет, то ответом должно быть число 0. помогите написать программу в паскаль.

Дан массив из n чисел. Найти номер первого чётного элемента массива; если чётных элементов нет, то ответом должно быть число 0. помогите написать программу в паскаль.
Гость
Ответ(ы) на вопрос:
Гость
program zadanie; const lmax=10; var n,i:integer; a:array [1..lmax] of integer; n1:real; flag: boolean; begin repeat       writeln('Введите длину массива меньше ',lmax);       read(n1); until (n1>0) and (n1<=lmax) and (n1=round(n1)); n:=round(n1); writeln('Введите целые элементы массива'); for i:=1 to n do     begin     repeat           read(n1);           if (n1<>round(n1)) then writeln('Введите ЦЕЛЫЙ элемент');     until (n1=round(n1));     a[i]:=round(n1);     end; flag:=false; i:=0;      repeat      i:=i+1;      if (a[i]mod 2=0) then         begin         flag:=true;         writeln('Номер первого четного элемента - ',i);         end;      until flag or (i=n); if (flag=false) then writeln('0') end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы