Дан массив Y(11). Составить программу обработки массива: 1. Найти сумму отрицательных элементов массива среди элементов, стоящих на нечетных местах. 2. Заменить все элементы, стоящие на нечетных местах, значениями их квадратов...

Дан массив Y(11). Составить программу обработки массива: 1. Найти сумму отрицательных элементов массива среди элементов, стоящих на нечетных местах. 2. Заменить все элементы, стоящие на нечетных местах, значениями их квадратов. 3. Подсчитать количество 1, стоящих на четных местах. Все это должно быть в одной задаче, решите плиз качественно, даю много баллов. Ах, да, все это на языке паскаль.
Гость
Ответ(ы) на вопрос:
Гость
const   n = 11; var   x: array[1..n] of integer;   i, k, d, s: integer; begin   Randomize;   Writeln('Элементы массива');   k := 0; s := 0;   for i := 1 to n do   begin     d := Random(11) - 5;     Write(d:3);     if (i mod 2) = 0 then begin { четное место }       if d = 1 then Inc(k);       x[i] := d     end     else begin       if d < 0 then s := s + d;       x[i] := sqr(d)     end   end;   Writeln;   Writeln('Результирующий массив');   for i := 1 to n do Write(x[i]:3);   Writeln;   Writeln('Количество единиц на четных местах равно ', k);   Writeln('Сумма отрицательных элементов на нечетных местах равна ', s) end. Тестовое решение: Элементы массива  -3  0 -5  1  5  1 -3 -4  5 -3 -2 Результирующий массив   9  0 25  1 25  1  9 -4 25 -3  4 Количество единиц на четных местах равно 2 Сумма отрицательных элементов на нечетных местах равна -13
Не нашли ответ?
Ответить на вопрос
Похожие вопросы