Дан вектор имеющий n (1 меньше =n меньше =100)целых элементов. напишите программу которая находит среднее арифметическое значение элементов, стоящих на нечётных позициях

Дан вектор имеющий n (1<=n<=100)целых элементов. напишите программу которая находит среднее арифметическое значение элементов, стоящих на нечётных позициях
Гость
Ответ(ы) на вопрос:
Гость
#include #include using namespace std; int main() {     unsigned short int n;     cout << "n = ";     cin >> n;     vector a;     int in,         avg,         s = 0,         c = 0;     for (int i = 0; i < n; ++i) {         cout << "a[" << i << "] = ";         cin >> in;         a.insert(a.end(), in);         if (i % 2 == 1) {             s += a.back();             c++;         }     }     avg = (int) s / c;     cout << "Среднее арифметическое элементов на нечётных позициях: "          << avg;     return 0; }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы