Дана длина в см. определите сколько полных метров и сколько осталось см. помогите написать программу по паскалю
Дана длина в см. определите сколько полных метров и сколько осталось см. помогите написать программу по паскалю
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1404 от 16.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var lsm:=ReadInteger('Укажите длину в см:');
if lsm<100 then Writeln(lsm,' см')
else begin
var lm:=lsm div 100;
Write(lsm div 100,'м');
lsm:=lsm mod 100;
if lsm<>0 then Write(' ',lsm,'cм');
Writeln
end
end.
Примеры
Укажите длину в см: 1623
16м 23cм
Укажите длину в см: 1200
12м
Укажите длину в см: 38
38 см
Не нашли ответ?
Похожие вопросы