Дана последовательность целых чисел A1, A2, ..., An. Составьте программу, которая выводит разность произведения элементов с нечётным индексом и суммы элементов с чётным индексом. 

Дана последовательность целых чисел A1, A2, ..., An. Составьте программу, которая выводит разность произведения элементов с нечётным индексом и суммы элементов с чётным индексом. 
Гость
Ответ(ы) на вопрос:
Гость
program gt; var a:array[1..1000]of integer; n,r,p,s,i:integer; begin read(N); p:=1;s:=0; for i:=1 to n do begin read(a[i]); if(i mod 2=1)then p:=p*a[i] else s:=s+a[i]; end; r:=p-s; writeln(r); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы