Дано натуральное число N (1 меньше =N меньше =10000). Требуется написать программу, определяющую для N, какая цифра больше - первая или последняя Тех. Требования: Входной файл: INPUT.TXT Выходной файл: OUTPUT.TXT Ограничение по...
Дано натуральное число N (1<=N<=10000). Требуется написать программу, определяющую для N, какая цифра больше - первая или последняя
Тех. Требования:
Входной файл: INPUT.TXT
Выходной файл: OUTPUT.TXT
Ограничение по времени 1 секунда
Формат входных данных:
В единственной строке задано число N.
Формат выходных данных:
В единственной стоке необходимо вывести один символ: "=", если цифры одинаковые"<", если первая цифра меньше последней, и ">", если первая цифра больше последней.
Пример файла входных данных:
1234
Пример файла выходных данных:
Ответ(ы) на вопрос:
var
n,d:integer;
f:Text;
begin
Assign(f,'input.txt'); Reset(f);
Read(f,n);
Assign(f,'output.txt'); Rewrite(f);
d:=n mod 10;
while n>=10 do n:=n div 10;
if n>d then Writeln(f,'>')
else
if n=d then Writeln(f,'=') else Writeln(f,'<');
Close(f)
end.
char * buffer = new char[1000];
ifstream filein("INPUT.TXT", ios::in);
filein.getline(buffer, 1000);
filein.close();
string str = string(buffer);
delete[] buffer;
ofstream fileout("OUTPUT.TXT", ios::out);
if (str[0] == str[str.length() - 1]) fileout << "=";
if (str[0] == str[str.length() - 1]) fileout << "<";
if (str[0] == str[str.length() - 1]) fileout << ">";
fileout.close();
Не нашли ответ?
Похожие вопросы