Дано натуральное число N. Напишите функцию (Pascal), вычисляющую сумму цифр числа N. Входные данные Задано единственное число N Выходные данные Необходимо вывести сумму цифр числа N. Примеры входные данные 12 выходные данные 3 ...

Дано натуральное число N. Напишите функцию (Pascal), вычисляющую сумму цифр числа N. Входные данные Задано единственное число N Выходные данные Необходимо вывести сумму цифр числа N. Примеры входные данные 12 выходные данные 3 ПРОГРАММА БЫЛА, НО ВВОДИЛ 12 И ВЫВОДИЛ ВМЕСТО 3, 0
Гость
Ответ(ы) на вопрос:
Гость
program pro; var n,a,sym:integer; begin readln(n); while n>0 do  begin  a:=n mod 10;   sym:=sym+a;  n:=n div 10;   end; writeln(sym) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы