Дано натуральное число n( трехзначное ) Составить программу которая вычисляет сумму цифр этого числа
Дано натуральное число n( трехзначное ) Составить программу которая вычисляет сумму цифр этого числа
Ответ(ы) на вопрос:
Код на Паскале:
Program proba;
Uses crt;
Var n,s:integer;
Begin
writeln('введите натуральное число');
Readln(n);
s:=0;
repeat s:=s+n mod 10;
n:=n div 10;until n=0;
writeln('сумма цифр ',s);
end.
P.S. Программа вычисляет не только трехзначные числа ;)
Не нашли ответ?
Похожие вопросы