Дано натуральное число найдите количество четных и нечетных цифр в нем. написать программу на паскале

Дано натуральное число найдите количество четных и нечетных цифр в нем. написать программу на паскале
Гость
Ответ(ы) на вопрос:
Гость
Var A,c,n:integer; Begin WriteLn('Введите натурально число'); Read(A); c:=0; n:=0; While A>0 do    Begin    if (A mod 10) mod 2 = 0 then c:=c+1;    if (A mod 10) mod 2 <> 0 then n:=n+1;    A:=A div 10;    End; WriteLn('Кол-во чётных цифр: ',c); WriteLn('Кол-во нечётных цифр: ',n); End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы