Дано натуральное число выяснить , является ли оно совершенным. Составить программ
Дано натуральное число выяснить , является ли оно совершенным. Составить программу. Кто знает , составте да программу пожалуйста.
Ответ(ы) на вопрос:
//Dev-C++ 5.11 (C)
#include <stdio.h>
int main(void)
{int n,sum;
sum=0;
scanf("%d",&n);
for(int i=1;i<n;i++)
if(n%i==0)sum=sum+i;
if(sum==n)
printf("Perfect number");
else
printf("Not perfect number");
return 0;} Пример ввода: 496 Пример вывода: Perfect number
sum=0;
scanf("%d",&n);
for(int i=1;i<n;i++)
if(n%i==0)sum=sum+i;
if(sum==n)
printf("Perfect number");
else
printf("Not perfect number");
return 0;} Пример ввода: 496 Пример вывода: Perfect number
Не нашли ответ?
Похожие вопросы