Дано некоторое число составьте программу которая выводит какое это число положительное или отрицательное если оно положительное уменьшить в 2 раза а в другом случае взвести в квадрат.
Дано некоторое число составьте программу которая выводит какое это число положительное или отрицательное если оно положительное уменьшить в 2 раза а в другом случае взвести в квадрат.
Ответ(ы) на вопрос:
//Pascal ABC.NET v3.1 сборка 1172
Var
a:real;
begin
readln(a);
if a>0 then writeln('Положительное, ',a/2) else
if a<0 then writeln('Отрицательное, ',sqr(a)) else
writeln('0');
end.
Пример ввода:
-12
Пример вывода:
-, 144
По моему такая задача уже несколько раз была здесь.
//Pascal
var a:integer;
begin
readln(a);
if a>0 then writeln('Положительное ', a/2)
else
if a<0 then writeln('Отрицательное', a*a);
if a=0 then writeln('0 - не положительное и не отрицательное число');
end.
Не нашли ответ?
Похожие вопросы