Дано шестизначное число. Написать программу, которая определяетявляется ли оно счастливым (сумма первых трех цифр равна сумме последних трех). Если число счастливое вывести на экран слово HAPPY, в противном случае вывести на эк...

Дано шестизначное число. Написать программу, которая определяетявляется ли оно счастливым (сумма первых трех цифр равна сумме последних трех). Если число счастливое вывести на экран слово HAPPY, в противном случае вывести на экран слово NO (никакие поясняющие записи в программе делать не нужно! библиотеку conio.h и команду getch() перед отправкой файла необходимо удалить!) в c++
Гость
Ответ(ы) на вопрос:
Гость
#include using namespace std; int main() { int n; cout << "n = "; cin >> n; if ( ( (int) n / 100000 ) + ( (int) (n % 100000) / 10000 ) + ( (int) (n % 10000) / 1000 ) == ( (int) (n % 1000) / 100 ) + ( (int) (n % 100) / 10 ) + ( (int) n % 10 ) ) { cout << "HAPPY" << endl; } else { cout << "NO" << endl; } return 0; }
Гость
#include using namespace std; int main() {     int A;     int B,C;     cin >> A;     B=0;     for (int i = 1; i<=3; i++)     {         B+=A%10;         A = A / 10;     }     C=0;     for (int i = 1; i<=3; i++)     {         C+=A%10;         A = A / 10;     }     if (B==C) cout << "HAPPY" << endl;     else cout << "NO" << endl;     return 0; }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы