Дано трёхзначное число. Напишите программу, которая определяет: а) есть ли среди цифр заданного целого трёхзначного числа одинаковые;пример входных данных: 123; 121; 222пример выходных данных: нет; да; даб) является ли число "п...
Дано трёхзначное число. Напишите программу, которая определяет:
а) есть ли среди цифр заданного целого трёхзначного числа одинаковые;
пример входных данных: 123; 121; 222
пример выходных данных: нет; да; да
б) является ли число "перевёртышем", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево.
Ответ(ы) на вопрос:
Гость
var x,a,b,c:integer;
begin
writeln ('введи трехзначное число');
readln (x);
c:=x mod 10;
b:=x div 10 mod 10;
a:=x div 100 mod 10;
if a=с then writeln ('Число является перевертышем')
else writeln ('число не является перевертышем');
if (a=b) or (a=c) or (b=c) then writeln ('да')
else writeln ('нет');
end.
Не нашли ответ?
Похожие вопросы