Даю 25 баллов!! Даны три целых числа. Найти произведение двух наибольших из них. Напишите программу в паскале.
Даю 25 баллов!! Даны три целых числа. Найти произведение двух наибольших из них. Напишите программу в паскале.
Ответ(ы) на вопрос:
program p1;
var a,b,c:integer;
begin
writeln('Введите число a');
read(a);
writeln('Введите число b');
read(b);
writeln('Введите число c');
read(c);
writeln('Производная двух максимальных чисел: ');
if a>b then
if c>b then write(a*c)
else
write(a*b)
else
if c>a then write(b*c)
else write(b*a);
end.
Решение с циклами. На мой взгляд, оно менее запутанное, чем с условиями.
Не нашли ответ?
Похожие вопросы