ДАЮ 60 БАЛЛОВ!! РЕШИТЕ НА PYTHON СРОЧНО НУЖНА ПОМОЩЬ!!! Вычислите N! ("эн-факториал") – произведение всех натуральных чисел от 1 до N ( N!=1∙2∙3∙…∙ N ). Входные данные Вводится единственное число N – натуральное, не превосходит...
ДАЮ 60 БАЛЛОВ!! РЕШИТЕ НА PYTHON
СРОЧНО НУЖНА ПОМОЩЬ!!!
Вычислите N! ("эн-факториал") – произведение всех натуральных чисел от 1 до N ( N!=1∙2∙3∙…∙ N ).
Входные данные
Вводится единственное число N – натуральное, не превосходит 12.
Выходные данные
Выведите полученное значение N!
Примеры
входные данные
2
выходные данные
2
входные данные
3
выходные данные
6
Ответ(ы) на вопрос:
Гость
прошу)
program time;var n, factorial, i: integer;begin factorial := 1; readln(n); for i := 1 to n do begin factorial := factorial * i; end; writeln(factorial);end.
Не нашли ответ?
Похожие вопросы